lunes, 21 de octubre de 2013

NVIDIA y Kernel 3.11

Este es un pequeño tutorial para las personas que hayan instalado (ya sea por update del SO o por algún otro medio) la última versión del kernel de Linux (3.11). Casualmente, es la que viene con la versión 13.10 de Ubuntu, y fue la que me trajo problemas para instalar los dirvers propietarios.

Al querer instalarlos, el mensaje de error hace referencia a no poder compilar el módulo del kernel. Para solucionar esto, hay que bajarse un parche, hecho por alguien del foro de NVIDIA y aplicarlo al paquete de instalación.

En mi caso, no me funcionó usar el parámetro --apply-patch, ya que acusa no encontrar el archivo a parchear. Lo que hice, fue lo siguiente


Una vez terminado el proceso, hay que ejectuar el instalador como root y asegurarse de no estar corriendo un X server. Para Ubuntu pueden hacer un service lightdm stop.